Network Manager doesn't show Wireless Interface wlan1

rogueap

(Joshep) #1

Continuing discussion from: Creating Rogue Access Point with 2 wireless interfaces

Why is my wlan1 not showing any networks ?


Creating Rogue Access Point with 2 wireless interfaces
(Hardeep Singh) #2

What do you mean?

hostapd is running on wlan1. are you expecting it to show wireless networks like wlan0?


(Joshep) #3

i restarted my network-manager
and plugged out my wlan1 adapter and again inserted it.
It didn’t detect any wifi ?


(Joshep) #4

it didn’t redirected me with
dnsspoof -i wlan1
I have to go manually through my browser
open some sites.
When i opened sites this site came instead of fake log in page


(Hardeep Singh) #5

probably because you set networkmanager.conf file to ignore wlan1.
did you do it earlier?


(Hardeep Singh) #6

Sites with HSTS header implementation won’t redirect. Majority of big sites are having strict-transport-security header enabled.

In Terminal run curl -I <site name> and look for strict-transport-security
If present, HSTS is enabled. if not. then dnsspoof will work on that site.

Test this site or https://rootsh3ll.com You will find HSTS enabled in curl output.


Evil Twin Attack [A Step by Step Guide] (Updated 2018)
(Joshep) #7

output of network-manager.conf

[main]
plugins = ifupdown,keyfile

[ifupdown]
managed = false

[keyfile]
managed-devices = interface-name:wlan0
managed-devices = interface-name:wlan1

airodump-ng wlan1mon
i can see the wifi’s with this command but can’t see on settings menu :frowning:


(Hardeep Singh) #8

I see you are running wlan1mon. which means card is in monitor mode already. that’s probably the reason you can’t see it in the settings menu.


(Joshep) #9

i even turned off the monitor mode but it didn’t detect any wifi
wlan1 is in managed mode too. :frowning:
This happened when i tried to create rogue access point.


(Hardeep Singh) #10

run ifconfig wlan1 up to turn up the interface.

maybe it’s down.


(Joshep) #11

Already did before but didn’t work.

But the wlan0 detects wiFi


(Joshep) #12

Finally I solved :slight_smile:
simply i changed managed = true and saved the network-manager .conf file

[main]
plugins = ifupdown,keyfile

[ifupdown]
managed = false

[keyfile]
managed-devices = interface-name:wlan0
managed-devices = interface-name:wlan1

to

[main]
plugins = ifupdown,keyfile

[ifupdown]
managed = true

[keyfile]
managed-devices = interface-name:wlan0
managed-devices = interface-name:wlan1

(Joshep) #13

Well when you gonna post about the captive portal topic?
Will the KRACK attack demo gonna release tomorrow?


(Hardeep Singh) #14

Currently working in the WiFi hacking in cloud lab article. will continue captive portal after that.
no plans for Krack demo as of now.


(Hardeep Singh) #15

Damn! I didn’t see that. Good finding :slight_smile: