How to Increase TXPower of a WiFi card and Does it Make Any Difference?

txpower
alfa

(NIXIE JAN M. JURADO) #1

Guys… Does anyone know how to bring this card into it’s highest dBm/mW? I could not bring it up, I tried switching its region to US and BO… and still, I didn’t get any good result. I even got into editing my crda…and It’s still in 20 dBm which is the default, right?..


(Hardeep Singh) #2

Removing the restrictions could be illegal in your country. Do it at your own risk

Setting the region to BO will push the card in the 30dBm range, though the AWUS036NHA usually operates at 800 mW (29 dBm)

Rather try setting the txpower directly, and see if that works for you

iwconfig wlan0 txpower 29

(Martin n) #3

Roomer has it! That this ‘Txpower’ tweak dosen’t make any difference at all!
Its just for show!

Personal opinion! Is! one time i made this work on kali Linux But actually i felt a huge performance drop by setting it to 30 dbm.

How Can 1000 of websites tell the same procedure, and have magic patches and still all faill! Maybe its a blind trusting way to destribute backdoors! To all pennys with wifi feaver??

Just a thought


(Hardeep Singh) #4

I disagree!

here’s my personal experience:

I live in a 3 floor building. 3rd is actually roof with a little room where the router resides. I faced no issues with my belkin router as it had longer antennas and maybe higher power transmissions.

but the day I switched my router with TP-link I saw that the signals weren’t reaching at the ground floor. I decided to flash the router and increase the tx power.
Installed openwrt on the tp link router. increased the power to max txpower possible.
and never had the signal issue again.

and just for information. I didn’t change router’s location by even a centimetre. It does make a difference. practically. without any backdoor.

Also, there’s no possible scenario for the backdoor since all the commands used for raising the txpower are installed by default on every Linux subsystem as a part of the coreutils package

In your case maybe the machine wasn’t powerful enough to provide enough boltage to card to operate at much higher txpower. try another machine.

better use a WiFi analyser graphic visualiser and see (at some distance) whether you see power increase them or not.


(Jennifer) #5

What would be a good wifi analyzer that has graphical representation?


(Hardeep Singh) #6

There are many. I’ll list the most famous and the most effective ones.

For Ubuntu/Debian machines

  1. The most famous - Kismet

On Ubuntu/Debian machines you can install Kismet using terminal command:

sudo apt-get install kismet

Then run in terminal using command kismet

  1. WaveMon

Ise apt-get utility to install wavemon as well

sudo apt-get install wavemon

then run command: wavemon

  1. The truly graphical - linSSID

I am not too sure about the active development of that tool. You can have a shot at it though. It is the truly graphical tool that you are looking for

  1. Most flexible and effective - Splunk

Splunk is a log aggregator and analysor. You can pass your airodump-ng scan into Splunk, in realtime and generate beautiful dashboards, charts and even demographics all in realtime.
It’s easy and simple to use.

  1. Most effective one - nmcli

It is a command line based tools but shows little bar graphs for signal strength so that can be iseful if you are locating a device or higher signal strength.

Usage:

nmcli d wifi

For Android:

Let me know if you need some other info as well :slight_smile:


(hello kitty) #7

it doesnt necasarily increase the radio power in the traditional sense, nor magicaly block any interference in the area between you and target. what it DOES to is increase the frequency band to which more data (packets) can fit in the same radio wave and this helps with issues such as frames being lost or packets dropping . with that said it does not magically make the antanae more powerful, as all the power of the antanae is determined by its hardware, the txpower setting is a softcoded value and differs country to country based on their FCC laws

from what i know i may be wrong


(hello kitty) #8

Your chipset comes with a huge antennae if i rerember, build a directional radar dish out of it. their are a whole bunch of youtube tutorials on this as you probably know.

802.11 wireless is a microwave frequency, its a very tightly packed wave that carries tremendous amount of data compressed in thousands of bands per second, microwaves have very poor omni directional output. But they naturally excell in very narow direction. some 3.5 GHZ microwave links for cellphone towers for example can go up to 2 miles but their radio coverage is shaped like a pencil so the cell phone towers usually have 6 of them circiling the tower to try and get the coverage to work.


(Hardeep Singh) #9

But, if we understand the fundamentals of txpower we see that the SI unit is milli-Watt which directly means power.
For example a card operating at 20 dBm, the absolute power must be 100mW to compensate the energy. and if it’s operating at 1000 dBm the power must be 1000mW or 1 Watt

Which simply states that the physical card does indeed requires more power to operate at that level of frequency. Although it is a soft-coded value but that’s like a command for the hardware ultimately, right?

So, isn’t it necessarily increasing the radio power?

Correct me if I missed something here.


This would be the case only if we switch from one channel to another.
For example,
Channel 1 operates on frequency range 2401 to 2403 MHz. See the chart below:

Channel # Lower Freq. Upper Freq.
1 2401 2423
2 2406 2428
3 2411 2433
4 2416 2438
5 2421 2443
6 2426 2448
7 2431 2453
8 2436 2458
9 2441 2463
10 2446 2468
11 2451 2473
12 2456 2478
13 2461 2483
14 2473 2495

From what I remember, even when we edit the CRDA source codes for our desired power values, say 30 dBm, we only changes the value from 20 dBm to 30 dBm in the same frequency domain. No matter what frequency it was. It just needed to be in the 2.4 GHz spectrum.

And in the commands we use to increase the txpower we never specify the channel, we do not need to right? it just works by simply changing the txpower: iwconfig wlan0 txpower 30. and if you check the operating frequency you’ll find that it hasn’t changed.

So, here I am confused if I am mistaken by the frequency concept or is it just a misconception from your side?

I’d like to have your views on this. I am curious to know @josepherickson135 !