Hashcat: No devices found/left error! [SOLVED]


(Steve) #1

While trying to crack the hccap file with the wordlist file I get the following error:



No devices found/left

I have tried this using the latest stable version of Hashcat and the beta version on github but no success.

This error appears to have something to do with the OpenCL runtime library but Im not sure what the next step is.

Any help would be much appreciated.

(Hardeep Singh) #2

This error means Hashcat couldn’t find any OpenCL devices installed on your system.

There are 2 possibilities for this:

  1. Graphics drivers aren’t installed
  2. You are using Kali under VM.

since you can’t access graphics card under a virtual machine you have 2 ways to go from here:

  1. Crack with Hashcat on host device, or
  2. Install Kali on main HDD

(Steve) #3

Thanks for prompt reply Harry.

However, I did not use my Kali VM because I know my graphics card is not supported directly in the VM but through Virtual drivers.

I installed it in my host OS which is Debian Stretch and tried 2 different versions as apparently there is a bug in the stable version!

I suppose I could install Kali natively on my Macbook but I’m sure there must be a quicker fix!

Thanks again.

(Hardeep Singh) #4

do you have graphics driver installed on Debian stretch?

as an alternative you can install Hashcat in MacBook. it’ll work better :slight_smile:

(Steve) #5

Yes, I have the update Nvidia driver installed. I am using my Macbook! I scrapped OSX years ago. I only have Linux installed.

(Steve) #6

My wife has a Macbook air with OSX installed, I suppose I could use her system just for Hashcat but I would prefer to have it on my own machine which is where I do my pentesting etc.

(Steve) #7

Having said that, I dont think the GPU on the Macbook Air is top spec!

(Hardeep Singh) #8

try hashcat with --force option.

(Hardeep Singh) #9

worth testing. it’ll give you a clear sense of hashcat in action.

(Steve) #10

I tried with --force option but I get the same error!

(Steve) #11

It looks like I’m going to have to do this on my wife’s Macbook but will have to be tomorrow now.

(Hardeep Singh) #12

can you show the complete error here?
also make sure that Debian detects your graphics card. see lspci

(Steve) #13

I already gave you the complete error message above and the Nvidia graphics card is detected and the drivers are installed. I installed them myself. I can access Nvidia-settings for confirmation.

(Hardeep Singh) #14

what does ./hashcat64.bin -I shows?

(Steve) #15

I dont have a hashcat64.bin file! This is running from a cloned repository in Github. i think the .bin file is only present on Windows is it not?

Previously to the Github install I had the stable version of Hashcat installed but it gave me the exact same error.

Does the OpenCL runtime library not have anything to do with this error?

(Hardeep Singh) #16

I am not quite sure about the github repo since I haven’t used it for a while now.

You can try the bin file directly from the latest stable release here: https://hashcat.net/hashcat/

It should. but as you said nvidia card is being detected by the system. I suspect the issue could be in the hashcat itself.
afterall its our job to triubleshoot. :wink:

(Steve) #17

I already had the sable release installed but cant remember if I downloaded it from the Hashcat site.

I will do that now and let you know the results.

I just love troubleshooting dont you? Its how you get better!

(Hardeep Singh) #18

exactly! that’s the reason we love Linux and have it as our main machine… for years now!

(Steve) #19

Yes, Ive been using Linux, various flavors for more than 10 years now. Will never go back to Windows or OSX!

(Steve) #20

Just installed the latest version from Hashcat’s website (the link you gave me) and I still get the same error!

I’m missing something but I don’t know what it is…YET!

I will pick this up again tomorrow.

Thanks for all your help Harry.